<!DOCTYPE html>
<html xmlns="http://www.w3.org/1999/xhtml" lang="en-US"> 
<head>
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
<meta name="distribution" content="global" />
<meta name="robots" content="follow, all" />
<meta name="language" content="en, sv" />
<meta name="viewport" content="width=device-width" /> 	<link rel="Shortcut Icon" href="/wp-content/uploads/2019/05/Screen-Shot-2019-05-03-at-9.40.26-AM.png" type="image/x-icon" />
<link rel="alternate" type="application/rss+xml" title="The University Star RSS 2.0" href="https://universitystar.com/feed/" />
<link rel="alternate" type="text/xml" title="The University Star RSS .92" href="https://universitystar.com/feed/rss/" />
<link rel="alternate" type="application/atom+xml" title="The University Star Atom 0.3" href="https://universitystar.com/feed/atom/" />


<title>Facial recognition technology allows autistic children to communicate &#8211; The University Star</title>
<link rel="alternate" type="application/rss+xml" title="The University Star &raquo; Facial recognition technology allows autistic children to communicate Comments Feed" href="https://universitystar.com/30327/news/facial-recognition-technology-allows-autistic-children-to-communicate/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/universitystar.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.2.1"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
			<style type="text/css">
				</style>
	<link rel='stylesheet' id='farbtastic-css'  href='https://universitystar.com/wp-admin/css/farbtastic.min.css?ver=1.3u1' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css'  href='https://universitystar.com/wp-includes/css/dashicons.min.css?ver=5.2.1' type='text/css' media='all' />
<link rel='stylesheet' id='thickbox-css'  href='https://universitystar.com/wp-includes/js/thickbox/thickbox.css?ver=5.2.1' type='text/css' media='all' />
<link rel='stylesheet' id='elusive-css'  href='https://universitystar.com/wp-content/plugins/menu-icons/vendor/codeinwp/icon-picker/css/types/elusive.min.css?ver=2.0' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome-css'  href='https://universitystar.com/wp-content/plugins/menu-icons/vendor/codeinwp/icon-picker/css/types/font-awesome.min.css?ver=4.7.0' type='text/css' media='all' />
<link rel='stylesheet' id='foundation-icons-css'  href='https://universitystar.com/wp-content/plugins/menu-icons/vendor/codeinwp/icon-picker/css/types/foundation-icons.min.css?ver=3.0' type='text/css' media='all' />
<link rel='stylesheet' id='menu-icons-extra-css'  href='https://universitystar.com/wp-content/plugins/menu-icons/css/extra.min.css?ver=0.11.5' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://universitystar.com/wp-includes/css/dist/block-library/style.min.css?ver=5.2.1' type='text/css' media='all' />
<link rel='stylesheet' id='crp-style-rounded-thumbs-css'  href='https://universitystar.com/wp-content/plugins/contextual-related-posts/css/default-style.css?ver=1.0' type='text/css' media='all' />
<style id='crp-style-rounded-thumbs-inline-css' type='text/css'>

.crp_related a {
  width: 150px;
  height: 150px;
  text-decoration: none;
}
.crp_related img {
  max-width: 150px;
  margin: auto;
}
.crp_related .crp_title {
  width: 100%;
}
                
</style>
<link rel='stylesheet' id='wpa-style-css'  href='https://universitystar.com/wp-content/plugins/wp-accessibility/css/wpa-style.css?ver=5.2.1' type='text/css' media='all' />
<link rel='stylesheet' id='wp-polls-css'  href='https://universitystar.com/wp-content/plugins/wp-polls/polls-css.css?ver=2.75.2' type='text/css' media='all' />
<style id='wp-polls-inline-css' type='text/css'>
.wp-polls .pollbar {
	margin: 1px;
	font-size: 6px;
	line-height: 8px;
	height: 8px;
	background: #d8e1eb;
	border: 1px solid #c8c8c8;
}

</style>
<link rel='stylesheet' id='googleFonts-css'  href='https://fonts.googleapis.com/css?family=Libre+Baskerville%3A400%2C700%7CTimes+New+Roman%2C+Times%2C+serif%3A400%2C700%7CLato%3A400%2C700%7CNews+Cycle%3A400%2C700%7CRoboto+Slab%3A400%2C700&#038;ver=5.2.1' type='text/css' media='all' />
<link rel='stylesheet' id='flex-parallax-css'  href='https://universitystar.com/wp-content/themes/snoflex/parallax/css/main.css?ver=20180212' type='text/css' media='all' />
<link rel='stylesheet' id='flex-flexslider-css'  href='https://universitystar.com/wp-content/themes/snoflex/tools/flexslider/flexslider.css?ver=20180207' type='text/css' media='all' />
<link rel='stylesheet' id='flex-superfish-css'  href='https://universitystar.com/wp-content/themes/snoflex/tools/superfish/css/superfish.css?ver=20180207' type='text/css' media='all' />
<link rel='stylesheet' id='flex-remodal-css'  href='https://universitystar.com/wp-content/themes/snoflex/javascript/remodal.css?ver=20180207' type='text/css' media='all' />
<link rel='stylesheet' id='flex-remodal-default-css'  href='https://universitystar.com/wp-content/themes/snoflex/javascript/remodal-default-theme.css?ver=20180207' type='text/css' media='all' />
<link rel='stylesheet' id='flex-stylesheet-css'  href='https://universitystar.com/wp-content/themes/snoflex/style.css?ver=20190523' type='text/css' media='all' />
<link rel='stylesheet' id='wp-paginate-css'  href='https://universitystar.com/wp-content/plugins/wp-paginate/css/wp-paginate.css?ver=2.0.5' type='text/css' media='screen' />
<script type='text/javascript' src='https://universitystar.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://universitystar.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var ai_front = {"wp_ai":"5.2.1+2.4.18","insertion_before":"BEFORE","insertion_after":"AFTER","insertion_prepend":"PREPEND CONTENT","insertion_append":"APPEND CONTENT","insertion_replace_content":"REPLACE CONTENT","insertion_replace_element":"REPLACE ELEMENT","cancel":"Cancel","use":"Use","add":"Add","parent":"Parent","cancel_element_selection":"Cancel element selection","select_parent_element":"Select parent element","css_selector":"CSS selector","use_current_selector":"Use current selector","element":"ELEMENT","path":"PATH","selector":"SELECTOR","visible":"VISIBLE","hidden":"HIDDEN"};
/* ]]> */
</script>
<script type='text/javascript' src='https://universitystar.com/wp-content/plugins/ad-inserter/includes/js/ai-jquery.js?ver=5.2.1+2.4.18'></script>
<script type='text/javascript' src='https://universitystar.com/wp-content/plugins/wp-accessibility/js/skiplinks.webkit.js?ver=5.2.1'></script>
<script type='text/javascript' src='https://universitystar.com/wp-content/themes/snoflex/javascript/jquery.min.js?ver=5.2.1'></script>
<script type='text/javascript' src='https://universitystar.com/wp-content/themes/snoflex/tools/flexslider/jquery.flexslider.js?ver=5.2.1'></script>
<script type='text/javascript' src='https://universitystar.com/wp-content/themes/snoflex/javascript/jquery-visible.js?ver=5.2.1'></script>
<script type='text/javascript' src='https://universitystar.com/wp-content/themes/snoflex/tools/superfish/js/hoverintent.js?ver=5.2.1'></script>
<script type='text/javascript' src='https://universitystar.com/wp-content/themes/snoflex/tools/superfish/js/superfish.js?ver=5.2.1'></script>
<script type='text/javascript' src='https://universitystar.com/wp-content/themes/snoflex/tools/superfish/js/supersubs.js?ver=5.2.1'></script>
<script type='text/javascript' src='https://universitystar.com/wp-content/themes/snoflex/javascript/jquery-scrolltofixed-min.js?ver=5.2.1'></script>
<script type='text/javascript' src='https://universitystar.com/wp-content/themes/snoflex/javascript/remodal.min.js?ver=5.2.1'></script>
<script type='text/javascript' src='https://universitystar.com/wp-content/themes/snoflex/javascript/jquery.cycle.all.min.js?ver=5.2.1'></script>
<script type='text/javascript' src='https://universitystar.com/wp-content/themes/snoflex/javascript/jcarousellite_1.0.1c4.js?ver=5.2.1'></script>
<script type='text/javascript' src='https://universitystar.com/wp-content/themes/snoflex/javascript/menus-init.js?ver=5.2.1'></script>
<script type='text/javascript' src='https://universitystar.com/wp-content/themes/snoflex/javascript/sno-image-effects.js?ver=20190208'></script>
<link rel='https://api.w.org/' href='https://universitystar.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://universitystar.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://universitystar.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Kerbey Lane Café expected to open spring 2020' href='https://universitystar.com/30324/news/kerbey-lane-cafe-expected-to-open-spring-2020/' />
<link rel='next' title='Historic season cut short for Bobcat baseball' href='https://universitystar.com/30328/sports/historic-season-cut-short-for-bobcat-baseball/' />
<meta name="generator" content="WordPress 5.2.1" />
<link rel="canonical" href="https://universitystar.com/30327/news/facial-recognition-technology-allows-autistic-children-to-communicate/" />
<link rel='shortlink' href='https://universitystar.com/?p=30327' />
<link rel="alternate" type="application/json+oembed" href="https://universitystar.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Funiversitystar.com%2F30327%2Fnews%2Ffacial-recognition-technology-allows-autistic-children-to-communicate%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://universitystar.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Funiversitystar.com%2F30327%2Fnews%2Ffacial-recognition-technology-allows-autistic-children-to-communicate%2F&#038;format=xml" />

<style type='text/css'>
	
		.wpa-hide-ltr#skiplinks a, .wpa-hide-ltr#skiplinks a:hover, .wpa-hide-ltr#skiplinks a:visited {  }
		.wpa-hide-ltr#skiplinks a:active,  .wpa-hide-ltr#skiplinks a:focus { background-color: #f1f1f1; box-shadow: 0 0 2px 2px rgba(0, 0, 0, 0.6); clip: auto; color: #0073aa; display: block; font-weight: 600; height: auto; line-height: normal; padding: 15px 23px 14px; position: absolute; left: 6px; top: 7px; text-decoration: none; text-transform: none; width: auto; z-index: 100000;  }
		
</style>
	<meta property="og:title" content="Facial recognition technology allows autistic children to communicate" />
	<meta property="og:type" content="article" />
	<meta name="author" content="Julie Gonzales" />
	<meta property="og:url" content="https://universitystar.com/30327/news/facial-recognition-technology-allows-autistic-children-to-communicate/" />
	<meta property="og:image" content="https://universitystar.com/wp-content/uploads/2019/06/23611A18-AE1A-4497-A0B3-9CBFE990C13E-900x564.jpg" />
	<meta property="og:image:width" content="900" />
	<meta property="og:image:height" content="564" />
	<meta property="og:site_name" content="The University Star" />
	<meta property="og:description" content="Members of the Texas State research and innovation group High-Performance Engineering have developed a mobile app benefiting children with autism spectrum disorder. Damian Valles, HiPE research group director, Maria Resendiz, associate professor of communication disorders and Inzamam Haque, in the electrical engineering masters program, developed and innovated engineering solutions for STEM, Health Care and other research fields..." />
	<meta name="description" content="Members of the Texas State research and innovation group High-Performance Engineering have developed a mobile app benefiting children with autism spectrum disorder. Damian Valles, HiPE research group director, Maria Resendiz, associate professor of communication disorders and Inzamam Haque, in the electrical engineering masters program, developed and innovated engineering solutions for STEM, Health Care and other research fields..." />
	<meta property="article:section" content="News" />
	<meta property="article:tag" content="" />
<!-- End of Facebook Meta Tags -->
<style type='text/css'>
.ai-viewport-3                { display: none !important;}
.ai-viewport-2                { display: none !important;}
.ai-viewport-1                { display: inherit !important;}
.ai-viewport-0                { display: none !important;}
@media (min-width: 768px) and (max-width: 979px) {
.ai-viewport-1                { display: none !important;}
.ai-viewport-2                { display: inherit !important;}
}
@media (max-width: 767px) {
.ai-viewport-1                { display: none !important;}
.ai-viewport-3                { display: inherit !important;}
}
</style>
<!-- Global site tag (gtag.js) - Google Analytics -->
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-68328713-1"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-68328713-1');
</script>
<script src="/wp-content/themes/snoflex/parallax/js/skrollr.js"></script>

<script>
	$(document).ready(function() {
		var wpadminbar = $('#wpadminbar').outerHeight();
		if (wpadminbar == null) { var wpadminbar = 0; }
		if ($('#wpadminbar').is(":hidden")) { wpadminbar = 0; }

	
			$('.navbarwrap').scrollToFixed({
			marginTop: wpadminbar,
			spacerClass: 'topnavspacer',
			zIndex: 2000
		});		
			
			var topmenuTop = $('.navbarwrap').offset().top;
		topmenuTop -= wpadminbar;
		$(window).scroll(function () {
			if ($(this).scrollTop() > topmenuTop) {
				$('#navbar .mini-logo').hide();
				$('#show-mini-logo-top').fadeIn();
				if ( $.isFunction($.fn.resizeMenuTop)) resizeMenuTop();
				
			} else {
				$('#show-mini-logo-top').hide();
				$('#navbar .mini-logo').fadeIn();
			}
		});
		
		
	
	});
</script>


<style type="text/css" media="screen">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</style>
</head>

<body data-rsssl=1><div class="leaderboardwrap">
	<div id="leaderboard">
	<div class="leaderboardadwrap" style="margin:0px auto;float:none;">
	<div class='code-block code-block-2' style='margin: 8px auto; text-align: center; display: block; clear: both;'>

<style type='text/css'>
.ai-rotate {position: relative;}
.ai-rotate-hidden {visibility: hidden;}
.ai-rotate-hidden-2 {position: absolute; top: 0; left: 0; width: 100%; height: 100%;}
.ai-list-data, .ai-ip-data, .ai-list-block {visibility: hidden; position: absolute; width: 100%; height: 100%; z-index: -9999;}
</style>
<div class='ai-rotate ai-2' data-info='WzIsM10=' style='position: relative;'>
<div class='ai-rotate-option' style='visibility: hidden;' data-name="QQ==" data-time="MTA=">
<a href="https://itunes.apple.com/us/app/university-star/id1435798047?mt=8" title="Download the University Star app.">
  <img src="https://universitystar.com/wp-content/uploads/2019/05/banner_ad_DOWNLOAD.jpg" alt="Download the University Star app through iTunes."/> </a></div>
<div class='ai-rotate-option' style='visibility: hidden; position: absolute; top: 0; left: 0; width: 100%; height: 100%;' data-name="Qg==" data-time="MTA=">
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- A. LeaderBoard filler-->
<ins class="adsbygoogle"
    style="display: inline-block;
     width:728px;height:90px;"
    data-ad-client="ca-pub-5742085468374518"
    data-ad-slot="5906687248"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
<div class='ai-rotate-option' style='visibility: hidden; position: absolute; top: 0; left: 0; width: 100%; height: 100%;' data-name="Qw==" data-time="MTA=">
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- A. LeaderBoard filler-->
<ins class="adsbygoogle"
    style="display: inline-block;
     width:728px;height:90px;"
    data-ad-client="ca-pub-5742085468374518"
    data-ad-slot="5906687248"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
</div>
</div>
	 </div>
	 
	 	
	</div>
</div>
<div class="topnavwrap">
	<div id="topnavbar">
			
			<div class="search-spacer"></div>

			<div class="topnavbarleft social-classic">
				<style>.topnavbarleft { padding: 0px; width:auto; }</style><a target="_blank" href="https://universitystar.com/feed/rss/"><div class="alt-header-social social-border sno-rss dashicons dashicons-rss"><span class="icon-hidden-text">RSS Feed</span></div></a><a target="_blank" href="https://www.youtube.com/user/theuniversitystar">
        		<div class="alt-header-social-fa social-border sno-youtube fa fa-youtube"><span class="icon-hidden-text">YouTube</span></div>
        	</a><a target="_blank" href="https://soundcloud.com/the-university-star">
        		<div class="alt-header-social-fa social-border sno-soundcloud fa fa-soundcloud"><span class="icon-hidden-text">SoundCloud</span></div>
        	</a><a target="_blank" href="https://www.linkedin.com/company/the-university-star">
	        	<div class="alt-header-social-fa social-border sno-linkedin fa fa-linkedin"><span class="icon-hidden-text">LinkedIn</span></div>
	        </a><a target="_blank" href="https://instagram.com/universitystar/">
        		<div class="alt-header-social-fa social-border sno-instagram fa fa-instagram"><span class="icon-hidden-text">Instagram</span></div>
        	</a><a target="_blank" href="https://twitter.com/universitystar">
        		<div class="alt-header-social social-border sno-twitter dashicons dashicons-twitter"><span class="icon-hidden-text">Twitter</span></div>
        	</a><a target="_blank" href="https://www.facebook.com/universitystar">
        		<div class="alt-header-social social-border sno-facebook dashicons dashicons-facebook-alt"><span class="icon-hidden-text">Facebook</span></div>
        	</a><div class="social-spacer"></div>			</div>

			<div class="topnavbarcenter">
                    <script src="https://universitystar.com/wp-content/themes/snoflex/javascript/date.js" type="text/javascript"></script>
        			</div>
	
			<div class="topnavbarright">
					<form method="get" id="searchform8048" action="https://universitystar.com/">
			<div class="search-button-container" id="searchthis8048">
			<button type="submit" disabled="disabled" id="sno-search-navbar-8048" class="sno-submit-search-button sno-search fa fa-search"><span class="icon-hidden-text">Submit Search</span></button>
			</div>
			<label for="s8048" class="assistive-text">Search</label>
			<input type="text" class="field s" name="s" id="s8048" placeholder="Search" onfocus="this.placeholder = ''" onblur="this.placeholder = 'Search'"/>
			<input type="submit" class="submit" name="submit" id="searchsubmit8048" style="display:none;" value="Search" />
		</form>
				</div>
	</div>
	<div class="clear"></div>
</div><div id="sno_mobile_menu"><ul class="slidemenu mobile-menu"><li class="mobile-search-side"><div class="sno-side-menu side-close-icon foundation-icons fi-x"><span class="icon-hidden-text">Close Menu</span></div><form method="get" class="searchform-alt-left" action="https://universitystar.com/">
									<label for="s-alt-left" class="assistive-text">Search</label>
									<input type="text" class="field" name="s" id="s-alt-left" placeholder="Search" onfocus="this.placeholder = ''" onblur="this.placeholder = 'Search'"/>
									<input type="submit" class="submit" name="submit" style="display:none;" value="Search" />
								</form></li><div class="clear"></div><div class="mobile-menu"><ul id="menu-top-nav" class="menu"><li id="menu-item-28016" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-28016"><a href="/"><i class="_mi dashicons dashicons-admin-home" aria-hidden="true" style="font-size:1.8em;vertical-align:text-bottom;"></i><span class="visuallyhidden">Home</span></a></li>
<li id="menu-item-9539" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-9539"><a title="News page" href="https://universitystar.com/category/news/">News</a>
<ul class="sub-menu">
	<li id="menu-item-29911" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29911"><a href="https://universitystar.com/category/news/breaking/">Breaking</a></li>
	<li id="menu-item-29915" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29915"><a href="https://universitystar.com/category/news/in-brief/">In Brief</a></li>
	<li id="menu-item-29918" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29918"><a href="https://universitystar.com/category/news/san-marcos/">San Marcos</a></li>
	<li id="menu-item-29914" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29914"><a href="https://universitystar.com/category/news/hays-county/">Hays County</a></li>
	<li id="menu-item-29920" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-29920"><a href="https://universitystar.com/category/news/university/">University</a>
	<ul class="sub-menu">
		<li id="menu-item-29917" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29917"><a href="https://universitystar.com/category/news/res-life/">Residential Life</a></li>
		<li id="menu-item-29913" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29913"><a href="https://universitystar.com/category/news/faculty-senate/">Faculty Senate</a></li>
		<li id="menu-item-29919" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29919"><a href="https://universitystar.com/category/news/student-government/">Student Government</a></li>
	</ul>
</li>
	<li id="menu-item-29912" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29912"><a href="https://universitystar.com/category/news/crime/">Crime</a></li>
	<li id="menu-item-29916" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29916"><a href="https://universitystar.com/category/news/obituaries/">Obituaries</a></li>
</ul>
</li>
<li id="menu-item-9543" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-9543"><a title="Life and Arts page" href="https://universitystar.com/category/life_and_arts/">Life &#038; Arts</a>
<ul class="sub-menu">
	<li id="menu-item-29923" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29923"><a href="https://universitystar.com/category/life_and_arts/fine-arts/">Fine Arts</a></li>
	<li id="menu-item-29921" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29921"><a href="https://universitystar.com/category/life_and_arts/fashion/">Fashion</a></li>
	<li id="menu-item-29924" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29924"><a href="https://universitystar.com/category/life_and_arts/food/">Food</a></li>
	<li id="menu-item-29925" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29925"><a href="https://universitystar.com/category/life_and_arts/humans-of-san-marcos/">Humans of San Marcos</a></li>
	<li id="menu-item-29926" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29926"><a href="https://universitystar.com/category/life_and_arts/music/">Music</a></li>
</ul>
</li>
<li id="menu-item-13047" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-13047"><a title="Sports page" href="https://universitystar.com/category/sports/">Sports</a>
<ul class="sub-menu">
	<li id="menu-item-29931" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29931"><a href="https://universitystar.com/category/sports/football/">Football</a></li>
	<li id="menu-item-29938" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29938"><a href="https://universitystar.com/category/sports/volleyball/">Volleyball</a></li>
	<li id="menu-item-29928" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29928"><a href="https://universitystar.com/category/sports/baseball/">Baseball</a></li>
	<li id="menu-item-29934" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29934"><a href="https://universitystar.com/category/sports/softball/">Softball</a></li>
	<li id="menu-item-29927" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29927"><a href="https://universitystar.com/category/sports/mens-basketball/">Men&#8217;s Basketball</a></li>
	<li id="menu-item-29935" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29935"><a href="https://universitystar.com/category/sports/womens-basketball/">Women&#8217;s Basketball</a></li>
	<li id="menu-item-29933" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29933"><a href="https://universitystar.com/category/sports/soccer/">Soccer</a></li>
	<li id="menu-item-29936" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29936"><a href="https://universitystar.com/category/sports/tennis/">Tennis</a></li>
	<li id="menu-item-29937" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29937"><a href="https://universitystar.com/category/sports/trackandfield/">Track and Field</a></li>
	<li id="menu-item-29930" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29930"><a href="https://universitystar.com/category/sports/cross-country/">Cross Country</a></li>
	<li id="menu-item-29932" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29932"><a href="https://universitystar.com/category/sports/golf/">Golf</a></li>
</ul>
</li>
<li id="menu-item-9425" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-9425"><a title="Opinions page" href="https://universitystar.com/category/opinions/">Opinions</a>
<ul class="sub-menu">
	<li id="menu-item-29940" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29940"><a href="https://universitystar.com/category/opinions/columns/">Columns</a></li>
	<li id="menu-item-29943" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29943"><a href="https://universitystar.com/category/opinions/letter_to_the_editor/">Letter to the Editor</a></li>
	<li id="menu-item-29942" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29942"><a href="https://universitystar.com/category/opinions/letter-from-the-editor/">Letter from the Editor</a></li>
	<li id="menu-item-29944" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29944"><a href="https://universitystar.com/category/opinions/reviews/">Reviews</a></li>
	<li id="menu-item-29945" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29945"><a href="https://universitystar.com/category/opinions/satire/">Satire</a></li>
</ul>
</li>
<li id="menu-item-29984" class="star-teal menu-item menu-item-type-post_type menu-item-object-page menu-item-29984"><a href="https://universitystar.com/events/">Events</a></li>
<li id="menu-item-22001" class="star-teal menu-item menu-item-type-post_type menu-item-object-page menu-item-22001"><a title="Advertising page" href="https://universitystar.com/advertising/">Advertising</a></li>
</ul></div></ul></div><div id="wrap" class="bodywrap"><div id="mobile-menu"><div class="sitetitle"><div class="headerlink headersmall" style="display:none"><img src="https://universitystar.com/wp-content/uploads/2019/05/Screen-Shot-2019-05-31-at-1.36.16-PM.png" class="headerimage" alt="Defending the First Amendment since 1911" /></div><div class="headerlink headermedium" style="display:none"><img src="https://universitystar.com/wp-content/uploads/2019/05/star_logo_tablet.png" class="headerimage" alt="Defending the First Amendment since 1911" /></div><div class="headerlink headerlarge"><img src="https://universitystar.com/wp-content/uploads/2019/05/UniStar-black_transparent.png" class="headerlink headerimage" alt="Defending the First Amendment since 1911" /></div><h1 style="display:none" aria-hidden="true">The University Star</h1><script type="text/javascript">
						$(document).ready(function(){
							$(".headerlink").click(function(){
								window.location="https://universitystar.com";

							});
						});
					</script><div id="hover-menu-side"><div class="sno-menu-side menu-icon dashicons dashicons-menu"><span class="icon-hidden-text">Menu</span></div></div></div><div class="clear"></div></div><div class="navbarwrap"><div class="navbarcontainer"><div id="navbar"><div id="navbarbackground"><div id="menu-a-menu"><nav aria-label="Secondary Menu"><div class="menu-top-nav-container"><ul id="menu-top-nav-1" class="sf-menu sno-top-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-28016"><a href="/"><i class="_mi dashicons dashicons-admin-home" aria-hidden="true" style="font-size:1.8em;vertical-align:text-bottom;"></i><span class="visuallyhidden">Home</span></a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-9539"><a title="News page" href="https://universitystar.com/category/news/">News</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29911"><a href="https://universitystar.com/category/news/breaking/">Breaking</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29915"><a href="https://universitystar.com/category/news/in-brief/">In Brief</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29918"><a href="https://universitystar.com/category/news/san-marcos/">San Marcos</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29914"><a href="https://universitystar.com/category/news/hays-county/">Hays County</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-29920"><a href="https://universitystar.com/category/news/university/">University</a>
	<ul class="sub-menu">
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29917"><a href="https://universitystar.com/category/news/res-life/">Residential Life</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29913"><a href="https://universitystar.com/category/news/faculty-senate/">Faculty Senate</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29919"><a href="https://universitystar.com/category/news/student-government/">Student Government</a></li>
	</ul>
</li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29912"><a href="https://universitystar.com/category/news/crime/">Crime</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29916"><a href="https://universitystar.com/category/news/obituaries/">Obituaries</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-9543"><a title="Life and Arts page" href="https://universitystar.com/category/life_and_arts/">Life &#038; Arts</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29923"><a href="https://universitystar.com/category/life_and_arts/fine-arts/">Fine Arts</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29921"><a href="https://universitystar.com/category/life_and_arts/fashion/">Fashion</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29924"><a href="https://universitystar.com/category/life_and_arts/food/">Food</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29925"><a href="https://universitystar.com/category/life_and_arts/humans-of-san-marcos/">Humans of San Marcos</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29926"><a href="https://universitystar.com/category/life_and_arts/music/">Music</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-13047"><a title="Sports page" href="https://universitystar.com/category/sports/">Sports</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29931"><a href="https://universitystar.com/category/sports/football/">Football</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29938"><a href="https://universitystar.com/category/sports/volleyball/">Volleyball</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29928"><a href="https://universitystar.com/category/sports/baseball/">Baseball</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29934"><a href="https://universitystar.com/category/sports/softball/">Softball</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29927"><a href="https://universitystar.com/category/sports/mens-basketball/">Men&#8217;s Basketball</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29935"><a href="https://universitystar.com/category/sports/womens-basketball/">Women&#8217;s Basketball</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29933"><a href="https://universitystar.com/category/sports/soccer/">Soccer</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29936"><a href="https://universitystar.com/category/sports/tennis/">Tennis</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29937"><a href="https://universitystar.com/category/sports/trackandfield/">Track and Field</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29930"><a href="https://universitystar.com/category/sports/cross-country/">Cross Country</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29932"><a href="https://universitystar.com/category/sports/golf/">Golf</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-9425"><a title="Opinions page" href="https://universitystar.com/category/opinions/">Opinions</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29940"><a href="https://universitystar.com/category/opinions/columns/">Columns</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29943"><a href="https://universitystar.com/category/opinions/letter_to_the_editor/">Letter to the Editor</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29942"><a href="https://universitystar.com/category/opinions/letter-from-the-editor/">Letter from the Editor</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29944"><a href="https://universitystar.com/category/opinions/reviews/">Reviews</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29945"><a href="https://universitystar.com/category/opinions/satire/">Satire</a></li>
</ul>
</li>
<li class="star-teal menu-item menu-item-type-post_type menu-item-object-page menu-item-29984"><a href="https://universitystar.com/events/">Events</a></li>
<li class="star-teal menu-item menu-item-type-post_type menu-item-object-page menu-item-22001"><a title="Advertising page" href="https://universitystar.com/advertising/">Advertising</a></li>
</ul></div></nav></div><ul id='menu-more-top' class='sf-menu sf-js-enabled sf-shadow' style='display:none'><li id="menu-more-item-top" style="float:left;"><a href="/" class="sf-with-ul">More<span class="sf-sub-indicator"> »</span></a>
								<ul id="add-more-top" class="sub-menu"></ul>
								</li>
							</ul></div></div></div></div><div class="clear"></div><div class="headerwrap"><div id="header" style="position:relative;"><div class="headerlarge"><a href="https://universitystar.com"><img src="https://universitystar.com/wp-content/uploads/2019/05/UniStar-black_transparent.png" class="headerimage" alt="Defending the First Amendment since 1911" /></a></div><h1 style="display:none">The University Star</h1></div></div>				<script type="text/javascript">
					$(document).ready(function() {
						$(".newsticker3-jcarousellite").jCarouselLite({
        					horizontal: true,
        					visible: 1,
        					auto:5000,
        					speed:2000    					});
					});
				</script><div id="fullwrap" style="position:relative;"><div class="innerbackgroundwrap"><div class="innerbackground"><div id='snopostid-30327' class='snopostid'><div id='classic_story' class='sno-story-30327'><div id="content"><div id='contentleft'><div class="postarea"><main><h1 class="storyheadline">Facial recognition technology allows autistic children to communicate</h1><div class="clear"></div><div class="permalinkphotobox"><div class="photowrap"><a class='modal-photosingle30327' href='#photo'><img src='https://universitystar.com/wp-content/uploads/2019/06/23611A18-AE1A-4497-A0B3-9CBFE990C13E-900x564.jpg' alt='The+Spring+2019+HiPE+Group.' style='width:100%' class='catboxphoto feature-image' /></a><div class='modal-photosingle30327 photo-enlarge elusive el-icon-zoom-in'></div><div class='remodal remodal-story-image sno-single-image' data-remodal-id='modal-photosingle30327' data-remodal-options='hashTracking: false, closeOnConfirm: false'><button data-remodal-action="close" class="remodal-close"><span class="icon-hidden-text">Close</span></button><div class="photo-container"><div class="sfi-header"><div class="sfi-return-to-story" data-remodal-action="cancel"><div class="fa fa-angle-left"><div class="icon-hidden-text">Back to Article</div></div><div class="sfi-back-text">Back to Article</div></div><div class="sfi-title-area"><p class="sfi-title">Facial recognition technology allows autistic children to communicate</p></div></div><div class='single-photo-wrap single-photo-container slideshow-photo-containersingle30327  sfi_has_caption'><img id="imagesingle30327" src="https://universitystar.com/wp-content/uploads/2019/06/23611A18-AE1A-4497-A0B3-9CBFE990C13E.jpg" alt="The Spring 2019 HiPE Group." class="enlarged-photo" data-width="1501" data-height="940"/></div><div class='photo-caption-container'><p class='photocaptionremodal'>The Spring 2019 HiPE Group.</p><p class='photocreditremodal'><p class="photocredit">Photo courtesy of HiPE</p></p></div><div class="clear"></div><div class="slideshow-caption-container-tablet"><p class='photocaptionremodal'>The Spring 2019 HiPE Group.</p><p class='photocredit'><p class="photocredit">Photo courtesy of HiPE</p></p></div></div></div><script type="text/javascript">
												$(document).ready(function() {
													$(function(){
														$('html').on('click', 'button.remodal-close', function(){
															sno_slideshow_open = 'no';
														});
														$('html').on('click', '.sfi-return-to-story', function(){
															sno_slideshow_open = 'no';
														});
														$('body').keypress(function(e){
															if(e.which == 27 || e.which == 0){
																sno_slideshow_open = 'no';
															}
														});									

														var sno_slideshow_open = 'no';
															$('html').on('wheel', function(event) {
																var delta = {
																	y: event.originalEvent.deltaY
																};
																			
															if (delta.y > 20 && sno_slideshow_open == 'yes') {
																	$('button.remodal-close').trigger('click');
																	sno_slideshow_open = 'no';
																}
															});
															
														$(".modal-photosingle30327").click(function() {
															sno_slideshow_open = 'yes';
															var inst = $("[data-remodal-id=modal-photosingle30327]").remodal();
															inst.open();
															scalephoto();
											//				var slideshow_area_heightsingle30327 = $('.single-photo-container').height(); 
											//				var photo_heightsingle30327 = 940;
											//		
											//				if (photo_heightsingle30327 < slideshow_area_heightsingle30327 ) {
											//					var top_marginsingle30327 = (slideshow_area_heightsingle30327 - photo_heightsingle30327)/2;
											//					$('#imagesingle30327').css("margin-top", top_marginsingle30327);
											//				}
														});
													});

						  							// let's make photos fully fill the frame if they are close to filling the frame and if they are large enough to start with
						  							
						  							function scalephoto() {
							  							$(".slideshow-photo-containersingle30327").each(function(){
								  							photo_w = $(this).find('img').attr('data-width');
								  							photo_h = $(this).find('img').attr('data-height');
								  							if (photo_h > 0) { photo_ratio = photo_w / photo_h; } else { photo_ratio = 2; }
								  							area_w = $(this).width();
								  							area_h = $(this).height();
								  							if (area_h > 0) { area_ratio = area_w / area_h; } else { area_ratio = 2; }
								  							photo_ratio = photo_ratio.toFixed(2); area_ratio = area_ratio.toFixed(2);
								  							ratio_diff = Math.abs(area_ratio - photo_ratio).toFixed(2);
								  							if (ratio_diff < .3 && photo_w > area_w * .7 && photo_h > area_h * .7) {
									  							$(this).find('img').addClass('forcefill');
									  						} else {
									  							$(this).find('img').removeClass('forcefill');
									  						}
							  							})
						  							}
													$(function() {
														scalephoto();
														window.onresize = function() {
															scalephoto();
											            };
													});

												});
										</script></div><div class="clear"></div><div class="captionboxmit"><p class="photocredit">Photo courtesy of HiPE</p><p class="photocaption">The Spring 2019 HiPE Group.</p></div></div><div class="storydetails"><p><span class="storybyline"> <a href="https://universitystar.com/staff/?writer=Julie%20Gonzales">Julie Gonzales</a>, News Reporter</span><br /><span class="storydate"><span class="time-wrapper">June 5, 2019</span></span><br /><span class="storycategory">Filed under <a href="https://universitystar.com/category/news/" rel="category tag">News</a>, <a href="https://universitystar.com/category/news/research/" rel="category tag">Research</a>, <a href="https://universitystar.com/category/news/university/" rel="category tag">University</a></span></p></div><div class="sharing sharing-top"><a data-remodal-target="modal"><div class="sharing-icon sno-email dashicons dashicons-email-alt sno-dark sharing-mobile-hide"><span class="icon-hidden-text">Share via Email</span></div></a></div>			<script type="text/javascript">
				$(document).ready(function() {
					$(function(){
						$('.modal-share').click(function() {
							var inst = $('[data-remodal-id=modal-share]').remodal();
							inst.open();

							var sharestoryid = '30327';

							$.ajax({
	                			url:"/wp-admin/admin-ajax.php",
								type:'POST',
								data:'action=sharestory&sharestoryid=' + sharestoryid,
								success:function(results)
	            					{ $(".suggestedstories").replaceWith(results); }
	           				});

						});
										
					});
				});
			</script>

			<div class="remodal" data-remodal-id="modal-share" data-remodal-options="hashTracking: false, closeOnConfirm: false">
  				<button data-remodal-action="close" class="remodal-close"><span class="icon-hidden-text">Close Modal Window</span></button>
  				<div class="suggestedstories">
  				<h1>Hang on for a minute...we're trying to find some more stories you might like.</h1>
  				<form method="post" action="">

  				<br />
  				<button data-remodal-action="cancel" class="remodal-cancel">Close</button>

  				</form>
  				</div>
			</div>

					<div class="remodal" data-remodal-id="modal" data-remodal-options="hashTracking: false, closeOnConfirm: false">
  				<button data-remodal-action="close" class="remodal-close"><span class="icon-hidden-text">Close Modal Window</span></button>
  				<div class="emailstoryform">
  				<h1>Email This Story</h1>
  				<form method="post" action="">
  				<label for="email_to_Above" style="display:none;">Send email to this address</label>
  				<input type="text" id="email_to_Above" name="email_to_Above" class="sno_email_fields" placeholder="Send email to this address"><br />
  				
  				<label for="email_from_Above" style="display:none;">Enter Your Name</label>
  				<input type="text" id="email_from_Above" name="email_from_Above" class="sno_email_fields" placeholder="Enter Your Name"><br />
  				
  				<label for="email_comment_Above" style="display:none;">Add a comment here</label>
  				<textarea rows="4" id="email_comment_Above" name="email_comment_Above" class="sno_email_fields" placeholder="Add a comment here (optional)."></textarea><br />
  				
  				<label for="human_Above" style="display:none;">Verification</label>
  				<input type="text" id="human_Above" name="human_Above" class="sno_email_fields" placeholder="What's 5 + 0?"><br />

  				<br />
  				<button id="submit_email_Above" data-remodal-action="confirm" class="remodal-confirm">Send Email</button>
  				<button data-remodal-action="cancel" class="remodal-cancel">Cancel</button>
  				<input type="hidden" id="sno_email_submission_form344442" name="sno_email_submission_form344442" value="8e40c8b2cf" /><input type="hidden" name="_wp_http_referer" value="/30327/news/facial-recognition-technology-allows-autistic-children-to-communicate/" />
  				</form>
  				</div>
			</div>
										<script>
								$(document).ready(function() {

								$(function(){
           							$('#submit_email_Above').click(function(){
											var storyid = '30327';
											var datastring = '';
											if ($("#email_to_Above").length > 0){
												var email_to = $('input[name=email_to_Above]');
												datastring += '&email_to=' + encodeURIComponent(email_to.val());
       										}

											if ($("#email_from_Above").length > 0){
												var email_from = $('input[name=email_from_Above]');
												datastring += '&email_from=' + encodeURIComponent(email_from.val());
       										}

											if ($("#email_comment_Above").length > 0){
												var email_comment = $('textarea[name=email_comment_Above]');
												datastring += '&email_comment=' + encodeURIComponent(email_comment.val());
       										}

											if ($("#human_Above").length > 0){
												var human = $('input[name=human_Above]');
												datastring += '&human=' + encodeURIComponent(human.val());
       										}
       										
	   										datastring += '&humanity=' + 5;

       										var verification = $('input[name=sno_email_submission_form344442]');
	   										datastring += '&verification=' + verification.val();
       										
										//	var parentid = '';
               							$.ajax({
                				            url:"/wp-admin/admin-ajax.php",
                				            type:'POST',
                				            data:'action=emailstory&storyid=' + storyid + datastring,
 	            				            success:function(results)
	            				            { $(".emailstoryform").replaceWith(results); }
	           				    	  	});
	         						});
								});
								});

							</script>

			<span class="storycontent"><p>Members of the Texas State research and innovation group <a href="http://hipe.wp.txstate.edu/" target="_blank" rel="nofollow noopener noreferrer">High-Performance Engineering</a> have developed a mobile app benefiting children with autism spectrum disorder.</p>
<p>Damian Valles, HiPE research group director, Maria Resendiz, associate professor of communication disorders and Inzamam Haque, in the electrical engineering masters program, developed and innovated engineering solutions for STEM, Health Care and other research fields as the mission for HiPE.</p>
<p>The idea for the project arose when the two departments, engineering and communication disorders, wanted to collaborate on a project, and the importance of autism was relevant.</p>
<p>According to the <a href="https://www.autismspeaks.org/what-autism" target="_blank" rel="nofollow noopener noreferrer">Autism Speaks foundation</a>, in 2018, 1 in 59 children were diagnosed with autism spectrum disorder by the CDC. This means 1 in 37 boys and 1 in 151 girls are affected by autism.</p>
<p>&#8220;If they can recognize and identify facial expressions, then we can decide what to do next,&#8221; said Resendiz. &#8220;The first step is to help with visuals and the next is to work on voice.&#8221;</p>
<p>Children with autism spectrum disorder will not have to see a speech-language pathologist in person with this application according to Resendiz. The mobility of the app has allowed users quick and easy access to speech-language therapy using telepractice. In fact, in a real-life situation, it allows children to practice receiving and participating in speech-language therapy in real time.</p>
<p>&#8220;It has been a really fun and great learning experience; it is great to have collaborators excited and students ready to apply what they have learned,&#8221; Resendiz said.</p>
<p>Inzamam Haque, active member of HiPE, joined the project because he wanted to do something in mission learning. Mission learning is an approach that allows students to find an association between themselves, their communities and a global community that is purposeful.</p>
<p>Since the project began, the team of three has completed literature research and studied different articles for several months, leading to Inzamam creating an algorithm. The group collected 2,800 images that would contribute to the application&#8217;s algorithm.</p>
<p>&#8220;I would like to see the children be helped so then the future group can create games for them to use and they can see if they are learning from this or not,&#8221; Inzamam said.</p>
<p>The facial recognition app is a prototype that has yet to go through clinical trials. It detects facial expressions, from left to right or up and down, and is compatible with working with different lighting conditions.</p>
<p>The app is sensitive to the idea children with autism may not always aim at a screen. Children can be at various angles or in a different light setting and the app will still allow for the translation.</p>
<p>The app was made so children with autism are able to open it easily. As the child looks through the camera and watches the screen, the background indicates the results of communication and shows the proper emoticon.</p>
<p>The app focuses on human interaction; children with autism love to play with mobile devices and this will help with bettering communication.</p>
<p>Valles would like to see the project gain more funding for research. In the future, this would allow the team to work on a voice feature so the child can detect certain voice and facial contexts such as sarcasm when communicating.</p>
<p>&#8220;We can improve the model much better with a microphone because a child with Autism can not identify sarcasm,&#8221; Valles said.</p>
<p>Once the app is finished, it will be free and opened sourced so others may work to improve the model. The application is available to everyone. This allows the team to gain more audience for the application and get free feedback.</p>
<p>&#8220;The impact provides a clever solution to families who need assistance to improve communication,&#8221; Valles said. &#8220;It showcases how engineering solutions can work.&#8221;</p>
</span><div class="clear"></div></main><div class="postmeta"></div><div class="aboutwriter"><div class='aboutwritertitle'>About the Writer</div>
<!-- profile displayed from cache -->
<div class='storycreditboxwide'><a href='https://universitystar.com/staff/?writer=Julie+Gonzales'><div class='sc_title'>Julie Gonzales, Author</div></a><div class='sc_bio' style='width:100%;'><p></p><div class='clear'></div></div></div><div class="clear"></div></div><div class='code-block code-block-1 ai-viewport-1 ai-viewport-2' style='margin: 8px auto; text-align: center; display: block; clear: both;'>

<style type='text/css'>
.ai-rotate {position: relative;}
.ai-rotate-hidden {visibility: hidden;}
.ai-rotate-hidden-2 {position: absolute; top: 0; left: 0; width: 100%; height: 100%;}
.ai-list-data, .ai-ip-data, .ai-list-block {visibility: hidden; position: absolute; width: 100%; height: 100%; z-index: -9999;}
</style>
<div class='ai-rotate ai-1' data-info='WzEsM10=' style='position: relative;'>
<div class='ai-rotate-option' style='visibility: hidden;' data-name="QQ==" data-time="MTA=">
<a href="https://www.dunham-mfg.com/college-class-rings/Texas-State-University">
    <img src="https://s3.amazonaws.com/pub.s3.flytedesk.com/ad/Texas-State-728x90-AD.jpg___5c747b65dff43/Texas-State-728x90-AD.jpg" alt="Texas State Class Rings Available">
</a></div>
<div class='ai-rotate-option' style='visibility: hidden; position: absolute; top: 0; left: 0; width: 100%; height: 100%;' data-name="Qg==" data-time="MTA=">
<a href="https://thelyndon.com/" title="The Lyndon Apartments">
  <img src="https://s3.amazonaws.com/pub.s3.flytedesk.com/ad/Lyndon-banner_ad.JPG___5ca84068123ff/Lyndon-banner_ad.JPG" alt="Live at the Lyndon Apartments.">
</a></div>
<div class='ai-rotate-option' style='visibility: hidden; position: absolute; top: 0; left: 0; width: 100%; height: 100%;' data-name="Qw==" data-time="MTA=">
<a href="https://havenatthorpelane.com/" title="Haven Apartments">
  <img src="https://s3.amazonaws.com/pub.s3.flytedesk.com/ad/Haven_Digital%20Ad.jpg___5ca84235e6d8a/Haven_Digital%20Ad.jpg" alt="Live at Haven Apartments.">
</a></div>
</div>
</div>
</div><script>
        		$(document).ready(function() {
    				$("#commentsbox").click(function() {
    			    	$("#commentsbody").slideToggle('slow');
    			    	$("#expand").toggle();
    			    	$("#collapse").toggle();
    				});
				});				
        		$(document).ready(function() {
    				$("#commentslink").click(function() {
    			    	$("#commentsbody").slideDown('slow');
    			    	$("#expand").hide();
    			    	$("#collapse").show();
    				});
				});				
			</script><div id="comments" class="sno-animate" style="height:60px;display:block"></div><div class="clear"></div><div id="commentswrap"><div class="widgetwrap"><div class="titlewrap cursorpoint" id="commentsbox"><div id="expand"><div class="fa fa-plus-square"></div></div><div id="collapse"><div class="fa fa-minus-square"></div></div><div class="widgettitle-nonsno">Leave a Comment</div></div><div id="commentsbody" class="widgetbody">


<!-- You can start editing here. -->



<div id="commentblock">




	
		<!-- If comments are open, but there are no comments. -->



	 








<p id="respond">
Section 230 of the Communications Decency Act states that "No provider or user of an interactive computer service shall be treated as the publisher or speaker of any information provided by another information content provider" (47 U.S.C. § 230). This means The University Star is protected as a platform and cannot be held liable for user-submitted comments. Additionally, The University Star retains CDA immunity while editors reserve the right to take down comments for any reason. Editors also reserve the right to refuse to take down comments that are not profane or libelous.  

By submitting comments to The University Star, commenters agree they have read and understand this policy. 
<br /><br />
If you want a picture to show with your comment, go get a <a href="http://en.gravatar.com" >gravatar</a>.</p>





<form action="https://universitystar.com/wp-comments-post.php" method="post" id="commentform">






<p><label for="name">Name (required)</label><br />

<input type="text" name="author" id="name" value="" size="50" tabindex="1" /></p>



<p><label for="email">Email Address (required)</label><br />

<input type="text" name="email" id="email" value="" size="50" tabindex="2" /></p>








<!--<p><small><strong>XHTML:</strong> You can use these tags: </small></p>-->


<div style="display:none"><label for="spam_stopper">Spam Control Field. Please Ignore</label><input type="text" name="sno_is_legit_comment" id="spam_stopper" value="SNO_Spam_Stopper"/></p></div>

	             		<script type="text/javascript">
							$(function(){
								$('input[name="sno_is_legit_comment"]').attr('name', 'sno_stop_spam');
							});
						</script>


<p><label for="words">Speak your mind</label><br /><textarea name="comment" id="words" cols="40" rows="10" tabindex="4"></textarea></p>



<p><input name="submit" type="submit" id="submit" tabindex="5" value="Submit Comment" />

<input type="hidden" name="comment_post_ID" value="30327" /></p>






</form>









</div></div><div class="widgetfooter"></div></div></div></div><div id="sidebar"><div style="clear:both"></div><section><div class="widgetwrap sno-animate"><div><div class='code-block code-block-3' style='margin: 8px auto; text-align: center; display: block; clear: both;'>

<style type='text/css'>
.ai-rotate {position: relative;}
.ai-rotate-hidden {visibility: hidden;}
.ai-rotate-hidden-2 {position: absolute; top: 0; left: 0; width: 100%; height: 100%;}
.ai-list-data, .ai-ip-data, .ai-list-block {visibility: hidden; position: absolute; width: 100%; height: 100%; z-index: -9999;}
</style>
<div class='ai-rotate ai-3' data-info='WzMsM10=' style='position: relative;'>
<div class='ai-rotate-option' style='visibility: hidden;' data-name="QQ==" data-time="MTA=">
<a href="https://www.customink.com/fundraising/university-star-spring-shirt"> <img src="https://universitystar.com/wp-content/uploads/2019/06/web_rectangle.jpg" alt="Buy the University Star T-Shirt."></a></div>
<div class='ai-rotate-option' style='visibility: hidden; position: absolute; top: 0; left: 0; width: 100%; height: 100%;' data-name="Qg==" data-time="MTA=">
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- B. Premium Rectangle filler -->
<ins class="adsbygoogle"
     style="display:inline-block;width:300px;height:250px;"
     data-ad-client="ca-pub-5742085468374518"
     data-ad-slot="5906687248"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
<div class='ai-rotate-option' style='visibility: hidden; position: absolute; top: 0; left: 0; width: 100%; height: 100%;' data-name="Qw==" data-time="MTA=">
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- B. Premium Rectangle filler -->
<ins class="adsbygoogle"
     style="display:inline-block;width:300px;height:250px;"
     data-ad-client="ca-pub-5742085468374518"
     data-ad-slot="5906687248"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
</div>
</div>
</div><div class="widgetfooter3"></div></div></section><section><div class='widgetwrap sno-animate sno-sno_text-5' style=''><div style="overflow: hidden;border-top: 2px solid #7d1c1e;background: #ffffff;margin-bottom:0px;"><div class="widget8 widgettitle" role="heading" style="background: #ffffff!important;background-color: #ffffff !important;color: #ffffff !important;padding: 0px 8px;font-size:14px !important;line-height: 22px!important;margin: 0px 0px 0px;10px;">Newsletter Sign Up</div></div><div class="clear"></div><div class="widgetbody8" style="background-color: #ffffff !important;border:none!important;"><div class="snotextwidget"><center><a href="https://universitystar.com/newsletter-signup/"><button class="button" role="newsletter signup">Sign up for our Newsletter!</button></a></center></div><div class="widget-expander" style="padding-bottom:0px"></div><div class="clear"></div></div></div></section><div style="clear:both"></div><section><div class="widgetwrap sno-animate"><div></div><div class="titlewrap" role="heading"><div class="widgettitle-nonsno">Related Stories</div></div><div class="widgetbody"><div class="crp_related_widget"><ul><li><a href="https://universitystar.com/29285/news/new-degrees-and-minor-to-be-offered-fall-2019/"    ><span class="crp_title">New degrees and minor to be offered fall 2019</span></a><span class="crp_author">  by <a href="https://universitystar.com/author/chase-rogers/">Chase Rogers</a></span> <span class="crp_date"> April 30, 2019</span> <span class="crp_excerpt"> Texas State will be offering three new bachelor’s degrees, a&hellip;</span></li><li><a href="https://universitystar.com/29291/news/study-abroad-experiences-gender-gap/"    ><span class="crp_title">Study abroad experiences gender gap</span></a><span class="crp_author">  by <a href="https://universitystar.com/author/anika/">Anika Adams</a></span> <span class="crp_date"> April 29, 2019</span> <span class="crp_excerpt"> Women statistically participate in study abroad programs more than men,&hellip;</span></li><li><a href="https://universitystar.com/29163/news/vaccine-preventable-diseases-sweep-the-country-including-texas/"    ><span class="crp_title">Vaccine-preventable diseases sweep the country, including Texas</span></a><span class="crp_author">  by <a href="https://universitystar.com/author/sierra-martin/">Sierra Martin</a></span> <span class="crp_date"> April 23, 2019</span> <span class="crp_excerpt"> Due to the growing popularity of vaccine exemptions, there have&hellip;</span></li><li><a href="https://universitystar.com/29420/life_and_arts/national-minority-health-month-brings-awareness-to-healthy-living/"    ><span class="crp_title">National Minority Health Month brings awareness to healthy living</span></a><span class="crp_author">  by <a href="https://universitystar.com/author/brianna-benitez/">Brianna Benitez</a></span> <span class="crp_date"> May 1, 2019</span> <span class="crp_excerpt"> The national&nbsp;Office of Minority Health&nbsp;(OMH) is challenging minorities to incorporate&hellip;</span></li></ul><div class="crp_clear"></div></div></div><div class="widgetfooter3"></div></div></section><div style="clear:both"></div><section><div class="widgetwrap sno-animate"><div><div class='code-block code-block-4' style='margin: 8px auto; text-align: center; display: block; clear: both;'>

<style type='text/css'>
.ai-rotate {position: relative;}
.ai-rotate-hidden {visibility: hidden;}
.ai-rotate-hidden-2 {position: absolute; top: 0; left: 0; width: 100%; height: 100%;}
.ai-list-data, .ai-ip-data, .ai-list-block {visibility: hidden; position: absolute; width: 100%; height: 100%; z-index: -9999;}
</style>
<div class='ai-rotate ai-4' data-info='WzQsM10=' style='position: relative;'>
<div class='ai-rotate-option' style='visibility: hidden;' data-name="QQ==" data-time="MTA=">
<a href = "https://itunes.apple.com/us/app/university-star/id1435798047?mt=8" title="Download the university star app!">
  <img src="https://universitystar.com/wp-content/uploads/2019/02/NEW_web_rectangle_1-1.jpg" alt="The University Star app is available for download on iTunes." style="height:250px;width:300px;"></a></div>
<div class='ai-rotate-option' style='visibility: hidden; position: absolute; top: 0; left: 0; width: 100%; height: 100%;' data-name="Qg==" data-time="MTA=">
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- C. Upper Rectangle -->
<ins class="adsbygoogle"
     style="display:inline-block;width:300px;height:250px"
     data-ad-client="ca-pub-5742085468374518"
     data-ad-slot="7411339902"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
<div class='ai-rotate-option' style='visibility: hidden; position: absolute; top: 0; left: 0; width: 100%; height: 100%;' data-name="Qw==" data-time="MTA=">
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- C. Upper Rectangle -->
<ins class="adsbygoogle"
     style="display:inline-block;width:300px;height:250px"
     data-ad-client="ca-pub-5742085468374518"
     data-ad-slot="7411339902"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
</div>
</div>
</div><div class="widgetfooter3"></div></div></section><div style="clear:both"></div><section><div class="widgetwrap sno-animate"><div><div class='code-block code-block-5' style='margin: 8px auto; text-align: center; display: block; clear: both;'>

<style type='text/css'>
.ai-rotate {position: relative;}
.ai-rotate-hidden {visibility: hidden;}
.ai-rotate-hidden-2 {position: absolute; top: 0; left: 0; width: 100%; height: 100%;}
.ai-list-data, .ai-ip-data, .ai-list-block {visibility: hidden; position: absolute; width: 100%; height: 100%; z-index: -9999;}
</style>
<div class='ai-rotate ai-5' data-info='WzUsM10=' style='position: relative;'>
<div class='ai-rotate-option' style='visibility: hidden;' data-name="QQ==" data-time="MTA=">
<a href = "https://universitystar.com/advertising/ " title="Advertise with The University Star.">
<img src = "https://s3.amazonaws.com/pub.s3.flytedesk.com/ad/NEW_web_rectangle_2.jpg___5c6dc7a722230/NEW_web_rectangle_2.jpg" alt="Place an ad with the University Star." style="width:300px;height:250px"></a></div>
<div class='ai-rotate-option' style='visibility: hidden; position: absolute; top: 0; left: 0; width: 100%; height: 100%;' data-name="Qg==" data-time="MTA=">
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- D. Lower Rectangle -->
<ins class="adsbygoogle"
     style="display:inline-block;width:300px;height:250px"
     data-ad-client="ca-pub-5742085468374518"
     data-ad-slot="3339778707"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
<div class='ai-rotate-option' style='visibility: hidden; position: absolute; top: 0; left: 0; width: 100%; height: 100%;' data-name="Qw==" data-time="MTA=">
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- D. Lower Rectangle -->
<ins class="adsbygoogle"
     style="display:inline-block;width:300px;height:250px"
     data-ad-client="ca-pub-5742085468374518"
     data-ad-slot="3339778707"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
</div>
</div>
</div><div class="widgetfooter3"></div></div></section></div></div></div></div><div class="sno_teaserbar" id="sno_teaserbar"><div class="stb_nav"><div class="custom-navigation"><span class="flex-prev"><div class="stb_left"><div class="fa fa-angle-left"><div class="icon-hidden-text">Navigate Left</div></div></div></span></div></div><div id='stb-container' class='flexslider'><ul class="slides"><li class='stb-top-row'><div class='stb_image'><a href='https://universitystar.com/30348/news/breaking/one-found-deceased-at-the-village-apartments-fifth-homicide-of-the-year/#photo'><img src='https://universitystar.com/wp-content/uploads/2016/09/police-lights-300x228.jpg' id='grow-stb30348'  style='height:70px;min-height:70px;width:auto;' class='catboxphoto' alt='Facial recognition technology allows autistic children to communicate'/></a></div><script type='text/javascript'>
									$(document).ready(function() {
   								 		$('#grow-stb30348').mouseenter(function() {
   											$('#grow-stb30348').removeClass('shrink');
   											$('#grow-stb30348').removeClass('grow');
   											$('#grow-stb30348').addClass('grow');
   										}).mouseleave(function() {
   											$('#grow-stb30348').addClass('shrink');
   										});});</script><p class='stb-cat'>Breaking</p><p class="relatedtitle"><a href="https://universitystar.com/30348/news/breaking/one-found-deceased-at-the-village-apartments-fifth-homicide-of-the-year/">One found deceased at The Village apartments, fifth homicide of the year</a></p></li><li class='stb-top-row'><div class='stb_image'><a href='https://universitystar.com/30337/news/animal-shelter-closes-cat-adoption-due-to-panleukopenia-virus/#photo'><img src='https://universitystar.com/wp-content/uploads/2018/10/6D3E41D4-A8FB-41BC-BB6D-9C21A8414DA9-300x225.jpeg' id='grow-stb30337'  style='height:70px;min-height:70px;width:auto;' class='catboxphoto' alt='Facial recognition technology allows autistic children to communicate'/></a></div><script type='text/javascript'>
									$(document).ready(function() {
   								 		$('#grow-stb30337').mouseenter(function() {
   											$('#grow-stb30337').removeClass('shrink');
   											$('#grow-stb30337').removeClass('grow');
   											$('#grow-stb30337').addClass('grow');
   										}).mouseleave(function() {
   											$('#grow-stb30337').addClass('shrink');
   										});});</script><p class='stb-cat'>Breaking</p><p class="relatedtitle"><a href="https://universitystar.com/30337/news/animal-shelter-closes-cat-adoption-due-to-panleukopenia-virus/">Animal shelter closes cat adoption due to Panleukopenia Virus</a></p></li><li class='stb-top-row'><div class='stb_image'><a href='https://universitystar.com/30324/news/kerbey-lane-cafe-expected-to-open-spring-2020/#photo'><img src='https://universitystar.com/wp-content/uploads/2019/06/Food_Grouped_OH-1-475x317.jpg' id='grow-stb30324'  style='height:70px;min-height:70px;width:auto;' class='catboxphoto' alt='Facial recognition technology allows autistic children to communicate'/></a></div><script type='text/javascript'>
									$(document).ready(function() {
   								 		$('#grow-stb30324').mouseenter(function() {
   											$('#grow-stb30324').removeClass('shrink');
   											$('#grow-stb30324').removeClass('grow');
   											$('#grow-stb30324').addClass('grow');
   										}).mouseleave(function() {
   											$('#grow-stb30324').addClass('shrink');
   										});});</script><p class='stb-cat'>News</p><p class="relatedtitle"><a href="https://universitystar.com/30324/news/kerbey-lane-cafe-expected-to-open-spring-2020/">Kerbey Lane Café expected to open spring 2020</a></p></li><li class='stb-top-row'><div class='stb_image'><a href='https://universitystar.com/30321/news/h-e-b-remodels-to-better-serve-the-community/#photo'><img src='https://universitystar.com/wp-content/uploads/2019/06/IMG_3751-2-475x317.jpg' id='grow-stb30321'  style='height:70px;min-height:70px;width:auto;' class='catboxphoto' alt='Facial recognition technology allows autistic children to communicate'/></a></div><script type='text/javascript'>
									$(document).ready(function() {
   								 		$('#grow-stb30321').mouseenter(function() {
   											$('#grow-stb30321').removeClass('shrink');
   											$('#grow-stb30321').removeClass('grow');
   											$('#grow-stb30321').addClass('grow');
   										}).mouseleave(function() {
   											$('#grow-stb30321').addClass('shrink');
   										});});</script><p class='stb-cat'>News</p><p class="relatedtitle"><a href="https://universitystar.com/30321/news/h-e-b-remodels-to-better-serve-the-community/">H-E-B remodels to better serve the community</a></p></li><li class='stb-top-row'><div class='stb_image'><a href='https://universitystar.com/30302/news/texas-state-switches-from-tracs-to-canvas/#photo'><img src='https://universitystar.com/wp-content/uploads/2019/06/Canvas-timeline-1-190x475.png' id='grow-stb30302'  style='width:70px;min-width:70px;' class='catboxphoto' alt='Facial recognition technology allows autistic children to communicate'/></a></div><script type='text/javascript'>
									$(document).ready(function() {
   								 		$('#grow-stb30302').mouseenter(function() {
   											$('#grow-stb30302').removeClass('shrink');
   											$('#grow-stb30302').removeClass('grow');
   											$('#grow-stb30302').addClass('grow');
   										}).mouseleave(function() {
   											$('#grow-stb30302').addClass('shrink');
   										});});</script><p class='stb-cat'>News</p><p class="relatedtitle"><a href="https://universitystar.com/30302/news/texas-state-switches-from-tracs-to-canvas/">Texas State switches from TRACS to Canvas</a></p></li></ul></div><div class="stb_nav"><div class="custom-navigation"><span class="flex-next"><div class="stb_right"><div class="fa fa-angle-right"><div class="icon-hidden-text">Navigate Right</div></div></div></span></div></div></div><div class="clear"></div><script type="text/javascript" charset="utf-8">
		$(document).ready(function() {
			$('#stb-container').flexslider({
				animation: "slide",
				animationLoop: true,
				customDirectionNav: $(".stb_nav .custom-navigation span"), 
       			slideshow: false,
				itemMargin: 2,
				touch: true,
				itemWidth: 250,
				minItems: 1,
				move: 1,
				maxItems: 5
  			});

  							//		animation: 'fade',
  							//		smoothHeight: false,
  							//		customDirectionNav: $("#sfi-navigation span"),
  							//		animationLoop: true,
  							//		slideshow: false,
  							//		touch: true



		});

			$(document).ready(function(){
			
			var TB_CurrentScroll = 0; var TB_NextScroll = 0; var hbheight = 0;
			
			
			$(window).scroll(function(event) {
				TB_CurrentScroll = TB_NextScroll;
				if ($('#sno_hoverbar').is(":visible")) { hbheight = 50 }
				TB_NextScroll = $(this).scrollTop();
				if (TB_NextScroll < TB_CurrentScroll && $(document).scrollTop() > 500) {  // scrolling up on the page causes it to display
					if ($('.sno_teaserbar').is(":hidden")) {
						$('.sno_teaserbar').show();
						$('.sno_teaserbar').stop().animate({ top: hbheight }, { duration: 300, queue: false });
					}
				}
				 else if ((TB_NextScroll > TB_CurrentScroll && $(document).scrollTop() > 500) || $(document).scrollTop() < 400 ){ // scrolling down on the page causes it to hide
					$('.sno_teaserbar').stop().animate({
						top: '-86px'
						},200, function(){
							$('.sno_teaserbar').hide();
						});
				} 
			});
				});
	</script></div></div></div><div style="clear:both;"></div><div class="footerwrap"><div id="footer"><div class="footername"></div><div class="clear"></div><div class="footermenu"><div class="menu-footer-menu-container"><ul id="menu-footer-menu" class="footer-menu"><li id="menu-item-26419" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-26419"><a href="https://universitystar.com/about/">About</a></li>
<li id="menu-item-29626" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-29626"><a href="https://universitystar.com/staff/">Staff</a></li>
<li id="menu-item-21984" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-21984"><a title="Advertising page" href="https://universitystar.com/advertising/">Advertising</a></li>
<li id="menu-item-28914" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-28914"><a href="https://universitystar.com/archives/">Archives</a></li>
<li id="menu-item-22243" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-22243"><a title="Contact page" href="https://universitystar.com/contact/">Contact</a></li>
<li id="menu-item-45" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-45"><a title="Jobs page" href="https://universitystar.com/jobs/">Jobs</a></li>
<li id="menu-item-19191" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-19191"><a title="Letter to the editor page" href="https://universitystar.com/letter-to-the-editor/">Letter to the editor</a></li>
<li id="menu-item-7492" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-7492"><a title="Donation page" href="https://donate.txstate.edu/donate?fid=BAE4TcjdDwc%3d&#038;fdesc=ldtprM4%2bJWtYxxZ2v0DJbNInFfFIveZ8xSZP578Qiaw%3d">Donate</a></li>
<li id="menu-item-19280" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-19280"><a title="Policies page" href="https://universitystar.com/policies/">Policies</a></li>
</ul></div></div><div class="footercredit"><p>&copy; 2019 All content, including web design &bull; <a target='_blank' href='/'>Privacy Policy</a> &bull; <a href='https://snosites.com/why-sno/'>FLEX WordPress Theme</a> by <a href='http://snosites.com'>SNO</a> &bull; <a href="https://universitystar.com/wp-login.php">Log in</a></p></div><div class="clear"></div></div></div><script type="text/javascript">
jQuery(window).load(function() {
	jQuery('.flexslider').animate({'opacity': 1}, { 'duration': 'slow'});
	jQuery('.flex-container').css('background', 'unset');
});

</script><script type="text/javascript">
	
	jQuery(document).ready(function(){
		// jQuery(".wp-caption").removeAttr('style');
		jQuery.each(jQuery(".wp-caption"), function(){
			jQuery(this).width(jQuery(this).find('img').attr('width'));
		});
	})
	$(function(){
		$(".s").focus(function(){
			$(".sno-submit-search-button").prop("disabled", false);
		});				
	});
    var top_level_links = $(".sf-menu").find('> li > a');
    // Set tabIndex to -1 so that top_level_links can't receive focus until menu is open
    $(top_level_links).next('ul')
        .attr({ 'aria-hidden': 'true', 'role': 'menu' })
        .find('a')
            .attr('tabIndex',-1);

    // Adding aria-haspopup for appropriate items
    $(top_level_links).each(function(){
        if($(this).next('ul').length > 0)
            $(this).parent('li').attr('aria-haspopup', 'true');
    });
   
jQuery( function() {
 	jQuery( '#hover-menu-side' ).on( 'touchstart click', function(e) {
 		e.preventDefault();
 			$('#sno_mobile_menu').fadeToggle();
		    $("body").toggleClass('noscroll');

 	});
 	jQuery( '.side-close-icon' ).on( 'touchstart click', function(e) {
 		e.preventDefault();
 			$('#sno_mobile_menu').fadeToggle();
			    $("body").toggleClass('noscroll');
 	});
 		
});

</script><!-- Code for ad blocking detection -->
<!--noptimize-->
<div id="banner-advert-container" class="ad-inserter chitika-ad" style="position:absolute; z-index: -10; height: 1px; width: 1px; top: -1px; left: -1px;"><img id="adsense" class="SponsorAds adsense" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"></div>
<script async src="https://www.google-analytics.com/analytics.js"></script>
<script async src="//contextual.media.net/dmedianet.js"></script>
<script type='text/javascript' src='https://universitystar.com/wp-content/plugins/ad-inserter/js/ads.js?ver=2.4.18'></script>
<script type='text/javascript' src='https://universitystar.com/wp-content/plugins/ad-inserter/js/sponsors.js?ver=2.4.18'></script>
<!--/noptimize-->
<script>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</script>

		<script>
			(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
			(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
			m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
			})(window,document,'script','//www.google-analytics.com/analytics.js','ga');
			ga('create', 'UA-139162439-2', 'auto');
			ga('require', 'displayfeatures');
			ga('send', 'pageview');
		</script> 	
		
	<script type='text/javascript'>
/* <![CDATA[ */
var thickboxL10n = {"next":"Next >","prev":"< Prev","image":"Image","of":"of","close":"Close","noiframes":"This feature requires inline frames. You have iframes disabled or your browser does not support them.","loadingAnimation":"https:\/\/universitystar.com\/wp-includes\/js\/thickbox\/loadingAnimation.gif"};
/* ]]> */
</script>
<script type='text/javascript' src='https://universitystar.com/wp-includes/js/thickbox/thickbox.js?ver=3.1-20121105'></script>
<script type='text/javascript' src='https://universitystar.com/wp-content/plugins/wp-accessibility/js/longdesc.button.js?ver=1.0'></script>
<script type='text/javascript' src='https://universitystar.com/wp-content/plugins/wp-accessibility/js/current-menu-item.js?ver=1.0'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var pollsL10n = {"ajax_url":"https:\/\/universitystar.com\/wp-admin\/admin-ajax.php","text_wait":"Your last request is still being processed. Please wait a while ...","text_valid":"Please choose a valid poll answer.","text_multiple":"Maximum number of choices allowed: ","show_loading":"1","show_fading":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://universitystar.com/wp-content/plugins/wp-polls/polls-js.js?ver=2.75.2'></script>
<script type='text/javascript' src='https://universitystar.com/wp-includes/js/wp-embed.min.js?ver=5.2.1'></script>

<script type='text/javascript'>
//<![CDATA[
(function( $ ) { 'use strict';
	$('body').prepend('<div class="wpa-hide-ltr" id="skiplinks" role="navigation" aria-label="Skip links"><a href="#content">Skip to content</a> <a href="#navbar">Skip to navigation</a> </div>'); $('#content').attr('tabindex','-1');$('#navbar').attr('tabindex','-1');
	$('a').removeAttr('target');
	
	$('input,a,select,textarea,button').removeAttr('tabindex');
	
}(jQuery));
//]]>
</script></div><div id="sno_hoversearch"><div class="sno-search-close foundation-icons fi-x" style="float:right;"></div><div class="hover-search-area"><form method="get" id="searchform-alt" action="https://universitystar.com/">
											<label for="s-alt" class="assistive-text">Search</label>
											<input type="text" class="field" name="s" id="s-alt" placeholder="Search" onfocus="this.placeholder = ''" onblur="this.placeholder = 'Search'"/>
											<input type="submit" class="submit" name="submit" id="searchsubmit-alt" value="Search" />
											<button type="submit" id="sno-hover-search-button" class="sno-submit-search sno-search fa fa-search"><span class="icon-hidden-text">Submit Search</span></button>
										</form></div></div><div id="sno_hoverbar"><div class="hoverheader"><div id="search-top"><div class="sno-search-button fa fa-search"><span class="icon-hidden-text">Activate Search</span></div></div><div class="socialmedia"><div class="sharing sharing-top"><a data-remodal-target="modal"><div class="sharing-icon sno-email dashicons dashicons-email-alt sno-dark sharing-mobile-hide"><span class="icon-hidden-text">Share via Email</span></div></a></div>			<script type="text/javascript">
				$(document).ready(function() {
					$(function(){
						$('.modal-share').click(function() {
							var inst = $('[data-remodal-id=modal-share]').remodal();
							inst.open();

							var sharestoryid = '30327';

							$.ajax({
	                			url:"/wp-admin/admin-ajax.php",
								type:'POST',
								data:'action=sharestory&sharestoryid=' + sharestoryid,
								success:function(results)
	            					{ $(".suggestedstories").replaceWith(results); }
	           				});

						});
										
					});
				});
			</script>

			<div class="remodal" data-remodal-id="modal-share" data-remodal-options="hashTracking: false, closeOnConfirm: false">
  				<button data-remodal-action="close" class="remodal-close"><span class="icon-hidden-text">Close Modal Window</span></button>
  				<div class="suggestedstories">
  				<h1>Hang on for a minute...we're trying to find some more stories you might like.</h1>
  				<form method="post" action="">

  				<br />
  				<button data-remodal-action="cancel" class="remodal-cancel">Close</button>

  				</form>
  				</div>
			</div>

					<div class="remodal" data-remodal-id="modal" data-remodal-options="hashTracking: false, closeOnConfirm: false">
  				<button data-remodal-action="close" class="remodal-close"><span class="icon-hidden-text">Close Modal Window</span></button>
  				<div class="emailstoryform">
  				<h1>Email This Story</h1>
  				<form method="post" action="">
  				<label for="email_to_Bar" style="display:none;">Send email to this address</label>
  				<input type="text" id="email_to_Bar" name="email_to_Bar" class="sno_email_fields" placeholder="Send email to this address"><br />
  				
  				<label for="email_from_Bar" style="display:none;">Enter Your Name</label>
  				<input type="text" id="email_from_Bar" name="email_from_Bar" class="sno_email_fields" placeholder="Enter Your Name"><br />
  				
  				<label for="email_comment_Bar" style="display:none;">Add a comment here</label>
  				<textarea rows="4" id="email_comment_Bar" name="email_comment_Bar" class="sno_email_fields" placeholder="Add a comment here (optional)."></textarea><br />
  				
  				<label for="human_Bar" style="display:none;">Verification</label>
  				<input type="text" id="human_Bar" name="human_Bar" class="sno_email_fields" placeholder="What's 6 + 2?"><br />

  				<br />
  				<button id="submit_email_Bar" data-remodal-action="confirm" class="remodal-confirm">Send Email</button>
  				<button data-remodal-action="cancel" class="remodal-cancel">Cancel</button>
  				<input type="hidden" id="sno_email_submission_form299401" name="sno_email_submission_form299401" value="3bcfb122ca" /><input type="hidden" name="_wp_http_referer" value="/30327/news/facial-recognition-technology-allows-autistic-children-to-communicate/" />
  				</form>
  				</div>
			</div>
										<script>
								$(document).ready(function() {

								$(function(){
           							$('#submit_email_Bar').click(function(){
											var storyid = '30327';
											var datastring = '';
											if ($("#email_to_Bar").length > 0){
												var email_to = $('input[name=email_to_Bar]');
												datastring += '&email_to=' + encodeURIComponent(email_to.val());
       										}

											if ($("#email_from_Bar").length > 0){
												var email_from = $('input[name=email_from_Bar]');
												datastring += '&email_from=' + encodeURIComponent(email_from.val());
       										}

											if ($("#email_comment_Bar").length > 0){
												var email_comment = $('textarea[name=email_comment_Bar]');
												datastring += '&email_comment=' + encodeURIComponent(email_comment.val());
       										}

											if ($("#human_Bar").length > 0){
												var human = $('input[name=human_Bar]');
												datastring += '&human=' + encodeURIComponent(human.val());
       										}
       										
	   										datastring += '&humanity=' + 8;

       										var verification = $('input[name=sno_email_submission_form299401]');
	   										datastring += '&verification=' + verification.val();
       										
										//	var parentid = '';
               							$.ajax({
                				            url:"/wp-admin/admin-ajax.php",
                				            type:'POST',
                				            data:'action=emailstory&storyid=' + storyid + datastring,
 	            				            success:function(results)
	            				            { $(".emailstoryform").replaceWith(results); }
	           				    	  	});
	         						});
								});
								});

							</script>

			</div><div id="back-top"><a id="snotop" href="#top" title="Return to Top"><div class="sno-arrow-up fa fa-arrow-up"><span class="icon-hidden-text">Scroll to Top</span></div></a></div><div class="lf_headerleft"><a href="/"><img src="https://universitystar.com/wp-content/uploads/2019/05/Screen-Shot-2019-05-31-at-1.36.16-PM.png" alt="Defending the First Amendment since 1911" /></a></div><div class="hover_title"><div class="hover_titletext">Facial recognition technology allows autistic children to communicate</div><span id="progress-bar"><span id="progress-bar-color"></span></span></div></div><div class="clear"></div></div><div id="hoverbar_menu"><ul class="slidemenu mobile-menu"><li class="mobile-search"><form method="get" class="searchform-alt-left" action="https://universitystar.com/">
									<label for="s-alt-left-hoverbar" class="assistive-text">Search</label>
									<input type="text" class="field" name="s" id="s-alt-left-hoverbar" placeholder="Search" onfocus="this.placeholder = ''" onblur="this.placeholder = 'Search'"/>
									<input type="submit" class="submit" name="submit" style="display:none;" value="Search" />
								</form></li><div class="clear"></div><div class="mobile-menu"><ul id="menu-top-nav-2" class="menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-28016"><a href="/"><i class="_mi dashicons dashicons-admin-home" aria-hidden="true" style="font-size:1.8em;vertical-align:text-bottom;"></i><span class="visuallyhidden">Home</span></a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-9539"><a title="News page" href="https://universitystar.com/category/news/">News</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29911"><a href="https://universitystar.com/category/news/breaking/">Breaking</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29915"><a href="https://universitystar.com/category/news/in-brief/">In Brief</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29918"><a href="https://universitystar.com/category/news/san-marcos/">San Marcos</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29914"><a href="https://universitystar.com/category/news/hays-county/">Hays County</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-29920"><a href="https://universitystar.com/category/news/university/">University</a>
	<ul class="sub-menu">
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29917"><a href="https://universitystar.com/category/news/res-life/">Residential Life</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29913"><a href="https://universitystar.com/category/news/faculty-senate/">Faculty Senate</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29919"><a href="https://universitystar.com/category/news/student-government/">Student Government</a></li>
	</ul>
</li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29912"><a href="https://universitystar.com/category/news/crime/">Crime</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29916"><a href="https://universitystar.com/category/news/obituaries/">Obituaries</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-9543"><a title="Life and Arts page" href="https://universitystar.com/category/life_and_arts/">Life &#038; Arts</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29923"><a href="https://universitystar.com/category/life_and_arts/fine-arts/">Fine Arts</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29921"><a href="https://universitystar.com/category/life_and_arts/fashion/">Fashion</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29924"><a href="https://universitystar.com/category/life_and_arts/food/">Food</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29925"><a href="https://universitystar.com/category/life_and_arts/humans-of-san-marcos/">Humans of San Marcos</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29926"><a href="https://universitystar.com/category/life_and_arts/music/">Music</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-13047"><a title="Sports page" href="https://universitystar.com/category/sports/">Sports</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29931"><a href="https://universitystar.com/category/sports/football/">Football</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29938"><a href="https://universitystar.com/category/sports/volleyball/">Volleyball</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29928"><a href="https://universitystar.com/category/sports/baseball/">Baseball</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29934"><a href="https://universitystar.com/category/sports/softball/">Softball</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29927"><a href="https://universitystar.com/category/sports/mens-basketball/">Men&#8217;s Basketball</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29935"><a href="https://universitystar.com/category/sports/womens-basketball/">Women&#8217;s Basketball</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29933"><a href="https://universitystar.com/category/sports/soccer/">Soccer</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29936"><a href="https://universitystar.com/category/sports/tennis/">Tennis</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29937"><a href="https://universitystar.com/category/sports/trackandfield/">Track and Field</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29930"><a href="https://universitystar.com/category/sports/cross-country/">Cross Country</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29932"><a href="https://universitystar.com/category/sports/golf/">Golf</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-9425"><a title="Opinions page" href="https://universitystar.com/category/opinions/">Opinions</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29940"><a href="https://universitystar.com/category/opinions/columns/">Columns</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29943"><a href="https://universitystar.com/category/opinions/letter_to_the_editor/">Letter to the Editor</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29942"><a href="https://universitystar.com/category/opinions/letter-from-the-editor/">Letter from the Editor</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29944"><a href="https://universitystar.com/category/opinions/reviews/">Reviews</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29945"><a href="https://universitystar.com/category/opinions/satire/">Satire</a></li>
</ul>
</li>
<li class="star-teal menu-item menu-item-type-post_type menu-item-object-page menu-item-29984"><a href="https://universitystar.com/events/">Events</a></li>
<li class="star-teal menu-item menu-item-type-post_type menu-item-object-page menu-item-22001"><a title="Advertising page" href="https://universitystar.com/advertising/">Advertising</a></li>
</ul></div></ul></div><script type="text/javascript">
		$(document).ready(function(){
			

			function sharingIconsResize() {
				if ($(window).width() < 850) {
					var socialwidth;
					var count = $("#mobile-socialmedia .sharing-mobile-show").length;
					if (count != 0) {
						socialwidth = 100 / count;
						$('#mobile-socialmedia .sharing-icon').width(socialwidth + '%');
					}
				} else {
					$('#sno_hoverbar .sharing-icon').width('50px');
				}
			}
						
			$('.sno-search-button').click(function() {
				$('#sno_hoversearch').fadeToggle();
				$('#sno_hoversearch').css({ top: '0' });
				$('#s-alt').focus();
			});
			$('.sno-search-close').click(function() {
				$('#sno_hoversearch').fadeToggle();
				$('#sno_hoversearch').css({ top: '-50px' });
			});

			var NavScrollTop		= $(window).scrollTop();
    		
    		if( $('.navbarwrap').length ) {
    			var	TopNavOffset 		= $('.navbarwrap').offset().top;
				var TopNavDistance		= (TopNavOffset - NavScrollTop);
   	 		}
   	 		if( $('.subnavbarwrap').length ) {
	   	 		var	BottomNavOffset 	= $('.subnavbarwrap').offset().top;
	   	 		var	BottomNavDistance	= (BottomNavOffset - NavScrollTop);
   	 		}
   	 		
   	 		$('#hoverbar_menu .mobile-menu').height( $(window).height() - 50);
   	 		
   	 		var HoverOffset = 0, HoverOffset2 = 0;
			   	 		var HoverHeight = $('#sno_hoverbar').outerHeight();
   	 		var HoverHeight2 = $('#sno_hoverbar').outerHeight();
   	 		
									
						if( $('.navbarwrap').length ) {
							HoverOffset2 += $('.navbarwrap').outerHeight();
							HoverHeight2 += $('.navbarwrap').outerHeight();
						}
			
			var CurrentScroll = 0;
			var WindowHeight = $(document).height() - $('.footerwrap').height();
			
							WindowHeight -= $('#commentswrap').height();		
						
			
			$('.sno-menu').click(function() {
			
				$('#hoverbar_menu').fadeToggle();
				$('.menu-icon').toggle();
				$('.close-icon').toggle();
				$('#hoverbar_menu').css({ height: $(window).height() - 50 });
			
			});
			
			$(window).scroll(function(event) {
				var NextScroll = $(this).scrollTop();

				var ScrollPercent = (NextScroll / (WindowHeight - $(window).height())) * 100;
				

				$('#progress-bar-color').css({ width: ScrollPercent + '%'});
				$('#hoverbar_menu').css({ top: $('#sno_hoverbar').height() });
				
				if ( ScrollPercent > 100 ) {
										$('.sno-arrow-up').css({ background: '#7d1c1e', color: '#eee'});
					$('.sno-menu').css({ background: '#7d1c1e', color: '#eee'});
					$('.socialmedia .sharing-icon').css({ opacity: 1 })
					
					
				} else {
										$('.sno-arrow-up').css({ background: '#7d1c1e', color: '#cccccc'});
					$('.sno-menu').css({ background: '', color: '#cccccc'});
				}
				var headerLocation = $("#wrap").offset().top;
				if (NextScroll > CurrentScroll && $(document).scrollTop() > headerLocation) {
					if ($('#sno_hoverbar').is(":hidden")) {
						$('#sno_hoverbar').show();
						$('#sno_hoverbar').stop().animate({ top: '0' }, { duration: 300, queue: false });
													if( $('.navbarwrap').length ) {
								$('.navbarwrap').stop().animate({ top: HoverHeight +'px'}, { duration: 300, queue: false });
							}
						
												
													var lpb = $('.lf_headerleft').width();
														var rpb = 50 + $('.socialmedia').width();
														$('#progress-bar').css({ left: lpb + 'px', right: rpb + 'px'})
						        			}


        			
				} else if (NextScroll < CurrentScroll && $(document).scrollTop() < ( headerLocation + 300 ) && $('#sno_hoverbar').is(":visible")) {
				
						$('#hoverbar_menu').hide();
						$('.close-icon').hide();
						$('.menu-icon').show();
						$('#hoverbar_menu').hide();
						$('#sno_hoverbar').stop().animate({
							top: '-50px'
							},300, function(){
								$('#sno_hoverbar').hide();
							});
						if ( $('.navbarwrap').length ) { $('.navbarwrap').stop().animate({ top: HoverOffset + 'px'},300); }
						if ( $('.subnavbarwrap').length ) { $('.subnavbarwrap').stop().animate({ top: HoverOffset2 + 'px'},300); }

				}
			CurrentScroll = NextScroll;
			});


		});

		$("#snotop").hide();
	
		$(function () {
			$(window).scroll(function () {
				if ($(this).scrollTop() > 500) {
					$('#snotop').fadeIn();
				} else {
					$('#snotop').fadeOut();
				}
			});

			$('#back-top a').click(function () {
				$('body,html').animate({
					scrollTop: 0
				}, 800);
				return false;
			});

		});
	</script></body></html>